]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/irssi/irssi_svn.bb
curl: update to 7.16.0 version by using patch from openembedded.org.
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / irssi / irssi_svn.bb
1 DESCRIPTION = "Irssi is a modular IRC client with Perl scripting."
2 HOMEPAGE = "http://irssi.org/"
3 SECTION = "console/network"
4 LICENSE = "GPL"
5 DEPENDS += "ncurses glib-1.2"
6 PV = "0.8.10+svn${CVSDATE}"
7 PR = "r2"
8
9 PACKAGES += "${PN}-common"
10 FILES_${PN} = "${bindir}/irssi"
11 FILES_${PN}-common = "${datadir}/irssi ${sysconfdir}"
12 RDEPENDS_${PN} += "${PN}-common"
13
14 inherit autotools
15
16 SRC_URI = "svn://svn.irssi.org/repos/irssi/;module=trunk;proto=http \
17            file://autofoo.patch;patch=1"
18 S = "${WORKDIR}/trunk"
19
20 EXTRA_OECONF = "--enable-ipv6 \
21                 --disable-ssl \
22                 --disable-glibtest \
23                 --without-socks \
24                 --with-textui \
25                 --without-bot \
26                 --without-proxy \
27                 --without-glib1 \
28                 --with-glib2 \
29                 --with-perl=no \
30                 --with-glib-prefix=${STAGING_LIBDIR}/.. \
31                 --with-glib-exec-prefix=${STAGING_LIBDIR}/.. \
32                 --with-ncurses=${STAGING_LIBDIR}/.."
33
34 do_configure () {
35         # create help files
36         echo "Creating help files..."
37         perl syntax.pl
38         
39         files=`echo docs/help/in/*.in|sed -e 's,docs/help/in/Makefile.in ,,' -e 's,docs/help/in/,!,g' -e 's/\.in /.in ?/g'`
40         cat docs/help/in/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/in/Makefile.am
41         
42         files=`echo $files|sed 's/\.in//g'`
43         cat docs/help/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/Makefile.am
44         
45         # .HTML -> .txt with lynx
46         # echo "Documentation: html -> txt..."
47         # lynx -dump -nolist docs/faq.html|perl -pe 's/^ *//; if ($_ eq "\n" && $state eq "Q") { $_ = ""; } elsif (/^([QA]):/) { $state = $1 } elsif ($_ ne "\n") { $_ = "   $_"; };' > docs/faq.txt
48         > docs/faq.txt
49         
50         autotools_do_configure
51 }
52
53 do_stage () {
54         find . -name \*.h | for h in `cat`; do
55                 install -d ${STAGING_LIBDIR}/../irssi/`dirname $h`
56                 install -m 0644 $h ${STAGING_LIBDIR}/../irssi/$h
57         done
58         find . -name lib\*.a | for l in `cat`; do
59                 install -d ${STAGING_LIBDIR}/../irssi/`dirname $l`
60                 install -m 0644 $l ${STAGING_LIBDIR}/../irssi/$l
61         done
62         install -m 0644 irssi-config ${STAGING_LIBDIR}/../irssi/
63 }
64
65 do_install () {
66         autotools_do_install
67         rm -f ${D}${docdir}/irssi/faq.txt
68 }