]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ixp425-eth/ixp425-eth_1.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ixp425-eth / ixp425-eth_1.1.bb
1 DEPENDS = "ixp4xx-csr patcher-native"
2 LICENSE = "GPL"
3 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
4 SRC_URI = "http://www.intel.com/design/network/swsup/ixp400LinuxEthernetDriverPatch-1_1.zip \
5            http://nslu.sourceforge.net/downloads/ixp425_eth.c.patch \
6            file://makefile.patch;patch=1 \
7            file://ethhdr.patch;patch=1 \
8            file://intdriven.patch;patch=1 \
9            file://pollcontroller.patch;patch=1 \
10            file://mm4.patch;patch=1"
11 SRC_URI += "file://2.6.13.patch;patch=1"
12 SRC_URI += "file://2.6.14.patch;patch=1"
13 PR = "r10"
14
15 S = "${WORKDIR}"
16
17 COMPATIBLE_HOST = "^armeb-linux.*"
18
19 inherit module
20
21 # Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
22 # required.  Notice that this has to be done for each separately built
23 # module as well!
24 KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
25 KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
26
27 do_pre_patch () {
28         patcher -p 0 -i ixp425_eth_1_1_update_nf_bridge.patch
29         patcher -f -p 0 -i ixp425_eth.c.patch
30 }
31
32 addtask pre_patch before do_patch
33
34 do_compile () {
35         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
36         oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
37                    'CC=${KERNEL_CC}' \
38                    'LD=${KERNEL_LD}' \
39                    'EXTRA_CFLAGS=-I${STAGING_INCDIR}/linux/ixp4xx-csr -I${STAGING_KERNEL_DIR}/include -DCPU=33 -DXSCALE=33'
40 }
41
42 do_install () {
43         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
44         install -m 0644 ixp425_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
45 }