]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/jack/jack_0.99.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / jack / jack_0.99.0.bb
1 DESCRIPTION = "JACK is a low-latency audio server. It can \
2 connect a number of different applications to an audio \
3 device, as well as allowing them to share audio between \
4 themselves."
5 SECTION = "libs/multimedia"
6 PRIORITY = "optional"
7 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
8 LICENSE = "GPL LGPL" 
9 PR = "r0"
10
11 SRC_URI = "${SOURCEFORGE_MIRROR}/jackit/jack-audio-connection-kit-${PV}.tar.gz"
12 S = "${WORKDIR}/jack-audio-connection-kit-${PV}"
13
14 inherit autotools pkgconfig
15
16 EXTRA_OECONF = "--enable-timestamps --disable-capabilities --disable-oldtrans \
17                 --disable-portaudio --disable-coreaudio --enable-oss --enable-alsa"
18
19 EXTRA_OEMAKE = 'transform="s,^,,"'
20
21 do_configure() {
22         gnu-configize
23         oe_runconf
24 }
25
26 do_install_append() {
27         install -d ${D}${docdir}
28         mv -f ${D}${datadir}/jack-audio-connection-kit ${D}${docdir}/
29 }
30
31 PACKAGES = "libjack jack-server jack-examples jack-doc jack-dev"
32 FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
33 FILES_jack-server = "${bindir}/jackd"
34 FILES_jack-examples = "${bindir}"