]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/jamvm/jamvm_1.3.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / jamvm / jamvm_1.3.0.bb
1 DESCRIPTION = "A compact Java Virtual Machine which conforms to the JVM specification version 2."
2 HOMEPAGE = "http://jamvm.sourceforge.net/"
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
6 SECTION = "interpreters"
7
8 DEPENDS = "zlib classpath"
9 RDEPENDS = "classpath (>= 0.14) classpath-common (>= 0.14)"
10
11 SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz \
12            file://heap-size.patch;patch=1"
13
14 inherit autotools update-alternatives
15
16 EXTRA_OECONF = "--with-classpath-install-dir=${prefix}"
17 CFLAGS += "-DDEFAULT_MAX_HEAP=16*MB"
18
19 PROVIDES = "virtual/java"
20 ALTERNATIVE_NAME = "java"
21 ALTERNATIVE_PATH = "${bindir}/jamvm"
22 ALTERNATIVE_PRIORITY = "10"