]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/jamvm/jamvm_1.4.2.bb
7897af1996a9bf4b3ee30a79f72de88f55453610
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / jamvm / jamvm_1.4.2.bb
1 # jamvm OE build file
2 # Copyright (C) 2006, Rene Wagner. All Rights Reserved
3 # Released under the MIT license (see org.handhelds.familiar/COPYING.MIT)
4
5 DESCRIPTION = "A compact Java Virtual Machine which conforms to the JVM specification version 2."
6 HOMEPAGE = "http://jamvm.sourceforge.net/"
7 LICENSE = "GPL"
8 PRIORITY = "optional"
9 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
10 SECTION = "interpreters"
11 PR = "r1"
12
13 DEPENDS = "zlib classpath"
14 RDEPENDS = "classpath (>= 0.20) classpath-common (>= 0.20)"
15
16 SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
17            file://jamvm-1.3.1-size-defaults.patch;patch=1 \
18            file://debian-jni.patch;patch=1"
19
20 # This uses 32 bit arm, so force the instruction set to arm, not thumb
21 ARM_INSTRUCTION_SET = "arm"
22
23 inherit autotools update-alternatives
24
25 EXTRA_OECONF = "--with-classpath-install-dir=${prefix}"
26 CFLAGS += "-DDEFAULT_MAX_HEAP=16*MB"
27
28 PROVIDES = "virtual/java"
29 ALTERNATIVE_NAME = "java"
30 ALTERNATIVE_PATH = "${bindir}/jamvm"
31 ALTERNATIVE_PRIORITY = "10"