]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/jamvm/jamvm_1.4.2.bb
d8024e8e844d2c777197418b808a5a1c49c8e02f
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / jamvm / jamvm_1.4.2.bb
1 DESCRIPTION = "A compact Java Virtual Machine which conforms to the JVM specification version 2."
2 HOMEPAGE = "http://jamvm.sourceforge.net/"
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
6 SECTION = "interpreters"
7
8 DEPENDS = "zlib classpath"
9 RDEPENDS = "classpath (>= 0.20) classpath-common (>= 0.20)"
10
11 SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz \
12            file://jamvm-1.3.1-size-defaults.patch;patch=1"
13
14 # This uses 32 bit arm, so force the instruction set to arm, not thumb
15 ARM_INSTRUCTION_SET = "arm"
16
17 inherit autotools update-alternatives
18
19 EXTRA_OECONF = "--with-classpath-install-dir=${prefix}"
20 CFLAGS += "-DDEFAULT_MAX_HEAP=16*MB"
21
22 PROVIDES = "virtual/java"
23 ALTERNATIVE_NAME = "java"
24 ALTERNATIVE_PATH = "${bindir}/jamvm"
25 ALTERNATIVE_PRIORITY = "10"