]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/keymaps/keymaps_1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / keymaps / keymaps_1.0.bb
1 DESCRIPTION = "Keyboard map"
2 SECTION = "base"
3 MAINTAINER = "Marcin Juszkiewicz <openembedded@hrw.one.pl>"
4 DEPENDS = "initscripts console-tools"
5 RDEPENDS = "initscripts console-tools"
6 LICENSE = "GPL"
7 PACKAGE_ARCH = "${MACHINE}"
8 PR = "r1"
9
10 inherit update-rc.d
11
12 SRC_URI = "file://keymap"
13
14 SRC_URI_append_c7x0         = " file://keymap-*.map"
15 SRC_URI_append_tosa         = " file://keymap-*.map"
16 SRC_URI_append_akita        = " file://keymap-*.map"
17 SRC_URI_append_spitz        = " file://keymap-*.map"
18 SRC_URI_append_borzoi       = " file://keymap-*.map"
19 SRC_URI_append_collie       = " file://keymap-*.map"
20 SRC_URI_append_poodle       = " file://keymap-*.map"
21
22 INITSCRIPT_NAME = "keymap"
23 INITSCRIPT_PARAMS = "start 00 S ."
24
25 do_install () {
26     install -d ${D}${sysconfdir}/init.d/
27     install -m 0755 ${WORKDIR}/keymap ${D}${sysconfdir}/init.d/
28
29     case ${MACHINE} in
30         c7x0 | tosa | spitz | akita | borzoi | collie | poodle )
31             install -m 0644 ${WORKDIR}/keymap-*.map     ${D}${sysconfdir}
32             ;;
33         *)
34             ;;
35     esac
36 }