]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/lcdproc/lcdproc_0.4.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / lcdproc / lcdproc_0.4.5.bb
1 DESCRIPTION = "LCDproc is a client/Server suite to drive all kinds of LCD (-like) devices. The client \
2 shipped with this package can be used to acquire various kinds of system stats."
3 HOMEPAGE = "http://lcdproc.org"
4 LICENSE ="GPL"
5 PRIORITY = "optional"
6 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
7 SECTION = "utils"
8
9 DEPENDS = "${@((bb.data.getVar('LCDPROC_DRIVERS',d) or 'curses,text').find('curses') != -1) and 'ncurses' or ''}"
10
11 SRC_URI = "${SOURCEFORGE_MIRROR}/lcdproc/lcdproc-${PV}.tar.gz"
12
13 inherit autotools
14
15 EXTRA_OECONF = "${@'--enable-drivers=' + (bb.data.getVar('LCDPROC_DRIVERS',d) or 'curses,text')}"
16
17 do_install () {
18         # binaries
19         install -D -m 0755 server/LCDd ${D}${sbindir}/LCDd
20         install -D -m 0755 clients/lcdproc/lcdproc ${D}${bindir}/lcdproc
21
22         # init scripts
23         install -D -m 0755 scripts/init-LCDd.debian ${D}${sysconfdir}/init.d/lcdd
24         # prevent lcdproc from starting if no SCREENS are set.
25         # will be fixed in next upstream release
26         cat scripts/init-lcdproc.debian | sed -e 's/C X//' | sed -e 's/case/[ -n $SCREENS ] || exit 0\n\ncase/' > ${D}${sysconfdir}/init.d/lcdproc
27         chmod 0755 ${D}${sysconfdir}/init.d/lcdproc
28
29         # configuration files
30         install -D -m 0644 LCDd.conf ${D}${sysconfdir}/LCDd.conf
31         # don't start lcdproc by default
32         # will be fixed in next upstream release
33         cat scripts/lcdproc.conf | sed -e 's/C X//' > ${D}${sysconfdir}/lcdproc.conf
34         chmod 0644 ${D}${sysconfdir}/lcdproc.conf
35 }
36
37 pkg_postinst () {
38         if test -n "${D}"; then
39                 D="-r $D"
40         fi
41         update-rc.d $D lcdd defaults 70 21
42         update-rc.d $D lcdproc defaults 71 20
43 }
44
45 pkg_prerm () {
46         if test -n "${D}"; then
47                 D="-r $D"
48         fi
49         update-rc.d $D lcdproc remove
50         update-rc.d $D lcdd remove
51 }