]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libaal/libaal_1.0.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libaal / libaal_1.0.4.bb
1 # This is the support library for reiser4progs, required when
2 # building that package.  The libraries from this build must
3 # be installed on the system to use the reiser4progs programs
4 PR = "r0"
5 DESCRIPTION = "Library for user-level code accessing Reiser4 filesystems"
6 HOMEPAGE = "http://www.namesys.com"
7 MAINTAINER = "John Bowler <jbowler@acm.org>"
8 SECTION = "base"
9 LICENSE = "GPL-2"
10
11 SRC_URI = "ftp://ftp.namesys.com/pub/reiser4progs/${P}.tar.gz"
12
13 inherit autotools
14
15 # This disables anything which uses libminimal - that library
16 # is used for boot loader stuff and so is not required unless
17 # the system will boot from a Reiser4 file system, the same
18 # setting must exist for the reiser4progs build
19 DISABLE_LIBMINIMAL ?= "--disable-libminimal"
20 EXTRA_OECONF = "${DISABLE_LIBMINIMAL}"
21
22 do_stage() {
23         echo "NOTE: stage package ${PF} is: (${PN},${PV},${PR})"
24         autotools_stage_includes
25         oe_libinstall -a -so -C src ${PN} ${STAGING_LIBDIR}
26 }