]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libao/libao_0.8.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libao / libao_0.8.4.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "A cross platform audio library"
3 HOMEPAGE = "http://www.xiph.org/ao/"
4 SECTION = "libs"
5 PRIORITY = "optional"
6 PR = "r1"
7
8 SRC_URI = "http://www.xiph.org/ao/src/libao-${PV}.tar.gz \
9            file://configure.patch;patch=1"
10
11 inherit autotools pkgconfig
12
13 EXTRA_OECONF = "--disable-esd --disable-esdtest \
14                 --disable-alsa --disable-alsa09 \
15                 --disable-arts --disable-nas"
16
17 do_stage() {
18         install -d ${STAGING_INCDIR}/ao
19         install -m 0644 ${S}/include/ao/ao.h ${S}/include/ao/os_types.h \
20                         ${S}/include/ao/plugin.h ${STAGING_INCDIR}/ao/
21
22         oe_libinstall -so -C src libao ${STAGING_LIBDIR}
23         install -d ${STAGING_DATADIR}/aclocal
24         install -m 0644 ao.m4 ${STAGING_DATADIR}/aclocal/
25 }
26
27 FILES_${PN} += "${libdir}/ao/plugins-2/*.so"