]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libao/libao_0.8.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libao / libao_0.8.6.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "A cross platform audio library"
3 HOMEPAGE = "http://www.xiph.org/ao/"
4 SECTION = "libs"
5 PRIORITY = "optional"
6 PR = "r0"
7
8 SRC_URI = "http://downloads.xiph.org/releases/ao/libao-${PV}.tar.gz"
9
10 inherit autotools pkgconfig
11
12 EXTRA_OECONF = "--disable-esd --disable-esdtest \
13                 --disable-alsa --disable-alsa09 \
14                 --disable-arts --disable-nas"
15
16 do_stage() {
17         install -d ${STAGING_INCDIR}/ao
18         install -m 0644 ${S}/include/ao/ao.h ${S}/include/ao/os_types.h \
19                         ${S}/include/ao/plugin.h ${STAGING_INCDIR}/ao/
20
21         oe_libinstall -so -C src libao ${STAGING_LIBDIR}
22         install -d ${STAGING_DATADIR}/aclocal
23         install -m 0644 ao.m4 ${STAGING_DATADIR}/aclocal/
24 }
25
26 FILES_${PN} += "${libdir}/ao/plugins-2/*.so"