]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libeventdb/libeventdb_0.17.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libeventdb / libeventdb_0.17.bb
1 LICENSE = "LGPL"
2 DESCRIPTION = "Database access library for GPE calendar"
3 SECTION = "gpe/libs"
4 PRIORITY = "optional"
5 MAINTAINER = "Philip Blundell <pb@handhelds.org>"
6 DEPENDS = "libgpewidget libgpepimc sqlite"
7
8 GPE_TARBALL_SUFFIX = "bz2"
9
10 inherit pkgconfig gpe autotools
11
12 headers = "event-db.h"
13
14 do_stage () {
15         oe_libinstall -so libeventdb ${STAGING_LIBDIR}
16
17         mkdir -p ${STAGING_INCDIR}/gpe
18         for h in ${headers}; do
19                 install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
20         done
21 }