]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libgc/libgc_6.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libgc / libgc_6.5.bb
1 DESCRIPTION     = "Garbage collector for C and C++"
2 LICENSE         = "As is"
3 HOMEPAGE        = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
4
5 DEPENDS         = "sed-native"
6 SRC_URI         = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc6.5.tar.gz"
7 S               = "${WORKDIR}/gc6.5" 
8 FILES_${PN}-doc += "/usr/share/gc/"
9
10 inherit autotools
11
12 do_configure_append() {
13         #fix libtool script
14          sed -i 's:${SED}:sed:g' libtool
15          sed -i 's:$SED:sed:g' libtool
16 }
17
18 do_stage() {
19         autotools_stage_includes
20         install -d ${STAGING_LIBDIR}
21         install -m 755 .libs/libgc.so* ${STAGING_LIBDIR}/
22 }