]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libgcrypt/libgcrypt_1.2.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libgcrypt / libgcrypt_1.2.0.bb
1 PR = "r2"
2 DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "GPL LGPL FDL"
6 DEPENDS = "libgpg-error"
7
8 # move libgcrypt-config into -dev package
9 FILES_${PN} = "${libdir}/lib*.so.*"
10 FILES_${PN}-dev += "${bindir}"
11
12 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz"
13
14 inherit autotools binconfig
15
16 EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
17
18 do_stage() {
19         oe_libinstall -so -C src libgcrypt ${STAGING_LIBDIR}
20         oe_libinstall -so -C src libgcrypt-pthread ${STAGING_LIBDIR}
21         install -m 0755 src/libgcrypt-config ${STAGING_BINDIR}/
22
23         install -d ${STAGING_INCDIR}/
24         for X in gcrypt.h gcrypt-module.h
25         do
26                 install -m 0644 src/${X} ${STAGING_INCDIR}/${X}
27         done
28
29 }