]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libiconv/libiconv_1.9.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libiconv / libiconv_1.9.2.bb
1 DESCRIPTION = "GNU libiconv - libiconv is for you if your application needs to support \
2 multiple character encodings, but that support lacks from your system."
3 HOMEPAGE = "http://www.gnu.org/software/libiconv"
4 SECTION = "e/libs"
5 PRIORITY = "optional"
6 MAINTAINER = "That Crazy fool emte <emte@labotomy.net>"
7 NOTES = "Needs to be stripped down to: ascii iso8859-1 eucjp iso-2022jp gb utf8"
8 PROVIDES = "virtual/libiconv"
9 PR = "r3"
10 LICENSE = "LGPL"
11 SRC_URI = "ftp://ftp.gnu.org/pub/gnu/libiconv/libiconv-${PV}.tar.gz"
12
13 S = "${WORKDIR}/libiconv-${PV}"
14
15 inherit autotools pkgconfig
16
17 EXTRA_OECONF += "--enable-shared --enable-static"
18
19 do_configure () {
20         rm -f m4/libtool.m4 libcharset/m4/libtool.m4
21         autotools_do_configure
22 }
23
24 do_stage () {
25         oe_libinstall -so -a -C lib libiconv ${STAGING_LIBDIR}
26         oe_libinstall -so -C lib libiconv_plug_linux ${STAGING_LIBDIR}
27         oe_libinstall -so -a -C libcharset/lib libcharset ${STAGING_LIBDIR}
28         autotools_stage_includes
29 }