]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libmikey/libmikey_0.1a.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libmikey / libmikey_0.1a.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "libmikey is a C++ library that implements the IETF work-in-progress MIKEY protocol."
3 HOMEPAGE = "http://minisip.org/libmikey"
4 SECTION = "libs"
5 PRIORITY = "optional"
6 DEPENDS = "openssl"
7
8 SRC_URI = "http://minisip.org/source/libmikey-${PV}.tar.gz"
9 S = "${WORKDIR}/libmikey-0.1"
10
11 inherit autotools 
12
13 do_configure() {
14         gnu-configize
15         oe_runconf
16 }
17
18 do_stage() {
19         oe_libinstall -so libmikey ${STAGING_LIBDIR}
20
21         install -d ${STAGING_INCDIR}/libmikey
22         install -m 0644 include/libmikey/*.h ${STAGING_INCDIR}/libmikey/
23 }