]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libnids/libnids_1.18.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libnids / libnids_1.18.bb
1 LICENSE = "GPL"
2 SECTION = "libs"
3 DEPENDS = "libnet libpcap"
4 DESCRIPTION = "Libnids performs assembly of TCP segments \
5 into TCP streams, IP defragmentation, and TCP port \
6 scan detection."
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/libnids/libnids-${PV}.tar.gz \
9            file://configure.patch;patch=1"
10
11 inherit autotools
12
13 EXTRA_OECONF = "--with-libpcap=${STAGING_LIBDIR}/.. \
14                 --with-libnet=${STAGING_LIBDIR}/.."
15 EXTRA_OEMAKE = "'install_prefix=${D}'"
16
17 do_stage () {
18         install -m 0644 ${S}/src/nids.h ${STAGING_INCDIR}/
19         oe_libinstall -a -C src libnids ${STAGING_LIBDIR}
20 }