]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libnss-mdns/libnss-mdns_0.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libnss-mdns / libnss-mdns_0.6.bb
1 DESCRIPTION = "NSS module for Multicast DNS name resolution"
2 HOMEPAGE = "http://0pointer.de/lennart/projects/nss-mdns/"
3 LICENSE = "GPL"
4 SECTION = "libs"
5 PRIORITY = "optional"
6
7 RRECOMMENDS_${PN} = "avahi-daemon zeroconf"
8 PR = "r1"
9
10 EXTRA_OECONF = "--libdir=/lib"
11 S = "${WORKDIR}/nss-mdns-${PV}"
12
13 SRC_URI = "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-${PV}.tar.gz \
14            file://alignment-fix.patch;patch=1"
15
16 inherit autotools
17
18 pkg_postinst () {
19         cat /etc/nsswitch.conf | grep "hosts:\s*files dns$" > /dev/null && {
20                 cat /etc/nsswitch.conf | sed 's/hosts:\s*files dns/& mdns/' > /tmp/nsswitch.conf
21                 mv /tmp/nsswitch.conf /etc/nsswitch.conf
22         }
23 }
24
25 pkg_prerm () {
26         cat /etc/nsswitch.conf | grep "hosts:\s*files dns mdns$" > /dev/null && {
27                 cat /etc/nsswitch.conf | sed 's/\(hosts:\s*files dns\) mdns/\1/' > /tmp/nsswitch.conf
28                 mv /tmp/nsswitch.conf /etc/nsswitch.conf
29         }
30 }