]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libsdl/libsdl-mixer_1.2.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libsdl / libsdl-mixer_1.2.6.bb
1 DESCRIPTION = "Simple DirectMedia Layer mixer library."
2 SECTION = "libs"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 DEPENDS = "virtual/libsdl"
6 LICENSE = "LGPL"
7 PR = "r2"
8
9 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
10 S = "${WORKDIR}/SDL_mixer-${PV}"
11
12 export SDL_CONFIG = "${STAGING_BINDIR}/sdl-config"
13
14 inherit autotools
15
16 EXTRA_OECONF = "--disable-music-mp3 --disable-music-libmikmod --disable-music-ogg"
17 # although we build smpeg... need to find out how
18 # to deal with optional dependencies
19
20 do_stage() {
21         oe_libinstall -so libSDL_mixer ${STAGING_LIBDIR}
22         ln -sf libSDL_mixer.so ${STAGING_LIBDIR}/libSDL_mixer-1.2.so
23         install -m 0644 SDL_mixer.h ${STAGING_INCDIR}/SDL/SDL_mixer.h
24 }
25