]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libsdl/libsdl-x11_1.2.7.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libsdl / libsdl-x11_1.2.7.bb
1 DESCRIPTION = "Simple DirectMedia Layer - X11 Edition"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
5 DEPENDS = "x11 xext"
6 PROVIDES = "virtual/libsdl"
7 LICENSE = "LGPL"
8
9 # NOTE: make sure to keep PR in sync with libsdl-qpe
10 PR = "r7"
11
12 SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
13            file://extra-keys.patch;patch=1 \
14            file://acinclude.m4"
15 S = "${WORKDIR}/SDL-${PV}"
16
17 inherit autotools binconfig
18
19 EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
20                 --enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
21                 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
22                 --disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
23                 --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
24                 --disable-video-xbios --disable-video-gem --disable-video-dummy \
25                 --disable-video-opengl --enable-input-events --enable-pthreads \
26                 --disable-video-picogui --disable-video-qtopia --enable-dlopen"
27
28 FILES_${PN} = "${libdir}/lib*.so.*"
29 FILES_${PN}-dev += "${bindir}/*config"
30
31 do_configure_prepend() {
32         rm -f ${S}/acinclude.m4
33         cp ${WORKDIR}/acinclude.m4 ${S}/
34 }
35
36 do_configure_append () {
37         cd ${S}
38
39         # prevent libtool from linking libs against libstdc++, libgcc, ...
40         cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
41         mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
42 }
43
44 do_stage() {
45         oe_libinstall -so -C src libSDL ${STAGING_LIBDIR}
46         rm ${STAGING_LIBDIR}/libSDL.la
47         ln -sf libSDL.so ${STAGING_LIBDIR}/libSDL-1.2.so
48         #oe_libinstall -a -C src/main libSDLmain ${STAGING_LIBDIR}
49         install -m 0644 src/main/libSDLmain.a ${STAGING_LIBDIR}
50
51         install -d ${STAGING_INCDIR}/SDL
52         for f in include/*.h
53         do
54                 install -m 0644 $f ${STAGING_INCDIR}/SDL/
55         done
56 }