]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libssh/libssh_0.11.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libssh / libssh_0.11.bb
1 SECTION = "libs"
2 DESCRIPTION = "The SSH library is a C library to authenticate in a \
3 simple manner to one or more SSH servers. The goal of this project \
4 is to provide a library much simpler to use than OpenSSHs one. It \
5 includes SFTP support, and a sample SSH client is provided."
6 DEPENDS = "openssl"
7 LICENSE = "LGPL"
8
9 SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
10
11 inherit autotools
12
13 EXTRA_OECONF = "--cache-file=${S}/config.cache"
14
15 do_stage () {
16         set -x
17         install -d ${STAGING_INCDIR}/libssh
18         for i in crypto.h libssh.h sftp.h ssh2.h; do
19                 install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
20         done
21         oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
22 }
23
24 do_install () {
25         oe_runmake "prefix=${D}${prefix}" \
26                    "exec_prefix=${D}${exec_prefix}" \
27                    "bindir=${D}${bindir}" \
28                    "incldir=${D}${includedir}" \
29                    "infodir=${D}${infodir}" \
30                    "mandir=${D}${mandir}/man1" \
31                    "libdir=${D}${libdir}" \
32                    install
33 }