]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libtomcrypt/libtomcrypt_0.97b.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libtomcrypt / libtomcrypt_0.97b.bb
1 DESCRIPTION = "LibTomCrypt is a fairly comprehensive, modular \
2 and portable cryptographic toolkit that provides developers \
3 with a vast array of well known published block ciphers, \
4 one-way hash functions, chaining modes, pseudo-random number \
5 generators, public key cryptography and a plethora of other \
6 routines."
7 SECTION = "libs/network"
8 PRIORITY = "optional"
9 LICENSE = "PD"
10 SRC_URI = "http://libtomcrypt.org/files/crypt-${PV}.tar.bz2"
11
12 inherit autotools
13
14 EXTRA_OEMAKE = "library"
15
16 #FIXME add patch to make it shared
17
18 do_stage() {
19         oe_libinstall -a libtomcrypt ${STAGING_LIBDIR}/
20         install -m 0644 *.h ${STAGING_INCDIR}/
21 }
22
23 do_install() {
24         :
25 }
26