]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libtool/libtool_1.5.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libtool / libtool_1.5.6.bb
1 DESCRIPTION = "Generic library support script \
2 This is GNU libtool, a generic library support script.  Libtool hides \
3 the complexity of generating special library types (such as shared \
4 libraries) behind a consistent interface."
5 HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
6 LICENSE = "GPL"
7 SECTION = "devel"
8 PR = "r2"
9
10 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
11            file://autotools.patch;patch=1"
12 S = "${WORKDIR}/libtool-${PV}"
13
14 PACKAGES = "libltdl libltdl-dev ${PN}"
15 FILES_${PN} += "${datadir}/aclocal*"
16 FILES_libltdl = "${libdir}/libltdl.so.*"
17 FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
18
19 inherit autotools
20
21 EXTRA_AUTORECONF = "--exclude=libtoolize"
22
23 do_configure () {
24         find ${S} -name acinclude.m4 | for m4 in `cat`; do
25                 cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
26         done
27         autotools_do_configure
28 }
29
30 do_stage () {
31         oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
32         install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
33 }