]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libtool/libtool_1.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libtool / libtool_1.5.bb
1 LICENSE = "GPL"
2 SECTION = "devel"
3 DESCRIPTION = "Generic library support script \
4 This is GNU libtool, a generic library support script.  Libtool hides \
5 the complexity of generating special library types (such as shared \
6 libraries) behind a consistent interface."
7 PR = "r1"
8
9 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
10            file://autotools.patch;patch=1"
11 S = "${WORKDIR}/libtool-${PV}"
12
13 inherit autotools
14
15 EXTRA_AUTORECONF = "--exclude=libtoolize"
16
17 PACKAGES = "libltdl libltdl-dev ${PN}"
18 FILES_${PN} += "${datadir}/aclocal*"
19 FILES_libltdl = "${libdir}/libltdl.so.*"
20 FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
21
22 do_configure () {
23         find ${S} -name acinclude.m4 | for m4 in `cat`; do
24                 cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
25         done
26         autotools_do_configure
27 }