]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libvorbis/libvorbis_1.0.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libvorbis / libvorbis_1.0.1.bb
1 SECTION = "libs"
2 DEPENDS = "libogg"
3 DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
4 that is free of intellectual property restrictions. libvorbis \
5 is the main vorbis codec library."
6 LICENSE = "BSD"
7 SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libvorbis-${PV}.tar.gz \
8 file://m4.patch;patch=1"
9
10 inherit autotools  pkgconfig
11
12 # vorbisfile.c reveals a problem in the gcc register spilling for the
13 # thumb instruction set...
14 FULL_OPTIMIZATION_thumb = "-O0"
15
16 EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
17                 --with-ogg-includes=${STAGING_INCDIR}"
18
19 do_stage () {
20         oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
21         oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
22         oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
23
24         install -d ${STAGING_INCDIR}/vorbis
25         install -m 0644 include/vorbis/vorbisenc.h \
26                         include/vorbis/vorbisfile.h \
27                         include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
28         install -d ${STAGING_DATADIR}/aclocal
29         install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
30 }