]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libxine/libxine-x11_1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libxine / libxine-x11_1.0.bb
1 DESCRIPTION = "libxine is a versatile multimedia library decoding a lot of common audio and video formats. \
2 This version is configued for the usage with X11"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "zlib libogg libvorbis tremor libmad libmodplug esound-gpe x11 xext"
7 PROVIDES = "virtual/libxine"
8 PR = "r0"
9
10 inherit autotools pkgconfig gettext binconfig
11
12 SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/xine/xine-lib-${PV}.tar.gz \
13         file://cpu-${PV}.patch;patch=1 \
14         file://configure-${PV}.patch;patch=1 \
15         file://libxine-tremor-autoconf.patch;patch=1 \
16         file://libxine-libvorbis.patch;patch=1 \
17         file://libxine-ffmpeg-enable-arm.patch;patch=1 \
18         file://no-caca-no-aalib.patch;patch=1 \
19         file://dont-have-xv.patch;patch=1 \
20         file://restore-esd.patch;patch=1 \
21         file://fix-syntax-xine-vorbis-decoder.patch;patch=1 \
22         file://libxine-cut-memusage.patch;patch=1 \
23         file://mpegvideo-static-inlinine.patch;patch=1 \
24         file://libxine-libavcodec.patch;patch=1"
25 S = "${WORKDIR}/xine-lib-${PV}"
26
27 SOV = "1.0.7"
28
29 EXTRA_OECONF="-with-zlib-path=${STAGING_DIR}/${HOST_SYS} \
30         --with-vorbis-prefix=${STAGING_DIR}/${HOST_SYS} \
31         --disable-oggtest \
32         --with-ogg-prefix=${STAGING_DIR}/${HOST_SYS} \
33         --disable-altivec --disable-vis --disable-mlib \
34         --disable-fb --disable-alsa --disable-vcd \
35         --disable-asf --disable-faad --disable-iconv \
36         --without-v4l --without-arts --without-sdl \
37         --without-xv  --without-xxmc --without-xvmc \
38         --with-x --x-includes=${STAGING_INCDIR}/X11 --x-libraries=${STAGING_LIBDIR}"
39                               
40 do_compile() {
41         oe_runmake LIBTOOL=${S}/${TARGET_SYS}-libtool
42 }
43
44 do_install() {
45         oe_runmake DESTDIR=${D} LIBTOOL=${S}/${TARGET_SYS}-libtool install
46 }
47
48 HEADERS="src/xine-engine/xineintl.h src/xine-utils/xineutils.h            \
49         src/xine-engine/xine_internal.h  src/xine-engine/xine_plugin.h    \
50         src/xine-utils/xine_buffer.h     src/xine-engine/video_out.h      \
51         src/xine-engine/buffer.h         src/xine-engine/vo_scale.h       \
52         src/xine-engine/configfile.h     src/xine-utils/attributes.h      \
53         src/xine-engine/info_helper.h    src/xine-engine/scratch.h        \
54         src/xine-engine/audio_decoder.h  src/input/input_plugin.h         \
55         src/xine-engine/spu_decoder.h    src/xine-engine/audio_out.h      \
56         src/xine-engine/io_helper.h      src/xine-engine/video_decoder.h  \
57         src/xine-engine/broadcaster.h    src/xine-engine/metronom.h       \
58         src/xine-utils/xmllexer.h        src/xine-engine/osd.h            \
59         src/xine-engine/video_overlay.h  src/xine-utils/xmlparser.h       \
60         src/xine-utils/compat.h          src/xine-engine/plugin_catalog.h \
61         src/xine-engine/post.h           src/demuxers/demux.h             \
62         src/xine-engine/resample.h       lib/os_types.h                   \
63         src/xine-engine/refcounter.h"
64
65 do_stage() {
66         install -d ${STAGING_INCDIR}/xine
67
68         install -m 0644 ${S}/include/xine.h ${STAGING_INCDIR}
69
70         for file in ${HEADERS}; do
71                 cp ${S}/$file ${STAGING_INCDIR}/xine/`basename $file`
72         done
73
74         install -m 0644 ${S}/m4/xine.m4 ${STAGING_DATADIR}/aclocal/
75
76         oe_libinstall -so -C src/xine-engine libxine ${STAGING_LIBDIR}
77 }
78
79 python populate_packages_prepend () {
80         bb.data.setVar('PKG_libxine', 'libxine', d)
81
82         plugindir = bb.data.expand('${libdir}/xine/plugins/1.0.0', d)
83         do_split_packages(d, plugindir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
84
85         postdir = bb.data.expand('${libdir}/xine/plugins/1.0.0/post', d)
86         do_split_packages(d, postdir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
87
88         fontdir = bb.data.expand('${datadir}/xine/libxine1/fonts', d)
89         do_split_packages(d, fontdir, '^(.*).xinefont.gz$', 'libxine-font-%s', 'Xine font %s', extra_depends='' )
90 }
91
92 # Omit the annoying xine-config in ${bindir}
93 FILES_${PN}="${libdir}/*.so*"
94
95 # And include it in the dev package
96 FILES_${PN}-dev += " ${bindir}"