]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libxine/libxine_1.1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libxine / libxine_1.1.0.bb
1 DESCRIPTION = "libxine is a versatile multimedia library decoding a lot of common audio and video formats. \
2 This version is configued for the usage with X11"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "zlib libogg libvorbis tremor libmad libmodplug esound-gpe x11 xext"
7 PROVIDES = "virtual/libxine"
8 PR = "r0"
9
10 inherit autotools pkgconfig gettext binconfig
11
12 SRC_URI = "${SOURCEFORGE_MIRROR}/xine/xine-lib-${PV}.tar.gz \
13     file://configure.patch;patch=1 \
14     file://cpuid.patch;patch=1 \
15     file://fix-syntax-xine-vorbis-decoder.patch;patch=1 \
16     file://libxine-arm-configure.patch;patch=1 \
17     file://libxine-cut-memusage.patch;patch=1 \
18     file://libxine-ffmpeg-enable-arm.patch;patch=1 \
19 #    file://libxine-libavcodec.patch;patch=1 \
20     file://tremor.patch;patch=1 \
21     file://libxine-tremor-autoconf.patch;patch=1 \
22     file://mpegvideo-static-inlinine.patch;patch=1 \
23     file://no-caca.patch;patch=1 \
24     file://dont-have-xv.patch;patch=1 \
25 "
26
27 DEFAULT_PREFERENCE = "-1"
28
29 S = "${WORKDIR}/xine-lib-${PV}"
30
31 SOV = "1.0.7"
32
33 EXTRA_OECONF="-with-zlib-path=${STAGING_DIR}/${HOST_SYS} \
34         --with-vorbis-prefix=${STAGING_DIR}/${HOST_SYS} \
35         --disable-oggtest \
36         --with-ogg-prefix=${STAGING_DIR}/${HOST_SYS} \
37         --disable-altivec --disable-vis --disable-mlib \
38         --disable-fb --disable-alsa --disable-vcd \
39         --disable-asf --disable-faad --disable-iconv \
40         --without-v4l --without-arts --without-sdl \
41         --without-xv  --without-xxmc --without-xvmc \
42         --with-x --x-includes=${STAGING_INCDIR}/X11 --x-libraries=${STAGING_LIBDIR}"
43
44 do_compile() {
45         oe_runmake LIBTOOL=${S}/${TARGET_SYS}-libtool
46 }
47
48 do_install() {
49         oe_runmake DESTDIR=${D} LIBTOOL=${S}/${TARGET_SYS}-libtool install
50 }
51
52 HEADERS="src/xine-engine/xineintl.h src/xine-utils/xineutils.h            \
53         src/xine-engine/xine_internal.h  src/xine-engine/xine_plugin.h    \
54         src/xine-utils/xine_buffer.h     src/xine-engine/video_out.h      \
55         src/xine-engine/buffer.h         src/xine-engine/vo_scale.h       \
56         src/xine-engine/configfile.h     src/xine-utils/attributes.h      \
57         src/xine-engine/info_helper.h    src/xine-engine/scratch.h        \
58         src/xine-engine/audio_decoder.h  src/input/input_plugin.h         \
59         src/xine-engine/spu_decoder.h    src/xine-engine/audio_out.h      \
60         src/xine-engine/io_helper.h      src/xine-engine/video_decoder.h  \
61         src/xine-engine/broadcaster.h    src/xine-engine/metronom.h       \
62         src/xine-utils/xmllexer.h        src/xine-engine/osd.h            \
63         src/xine-engine/video_overlay.h  src/xine-utils/xmlparser.h       \
64         src/xine-utils/compat.h          src/xine-engine/plugin_catalog.h \
65         src/xine-engine/post.h           src/demuxers/demux.h             \
66         src/xine-engine/resample.h       lib/os_types.h                   \
67         src/xine-engine/refcounter.h"
68
69 do_stage() {
70         install -d ${STAGING_INCDIR}/xine
71
72         install -m 0644 ${S}/include/xine.h ${STAGING_INCDIR}
73
74         for file in ${HEADERS}; do
75                 cp ${S}/$file ${STAGING_INCDIR}/xine/`basename $file`
76         done
77
78         install -m 0644 ${S}/m4/xine.m4 ${STAGING_DATADIR}/aclocal/
79
80         oe_libinstall -so -C src/xine-engine libxine ${STAGING_LIBDIR}
81 }
82
83 python populate_packages_prepend () {
84         bb.data.setVar('PKG_libxine', 'libxine', d)
85
86         plugindir = bb.data.expand('${libdir}/xine/plugins/1.1.0', d)
87         do_split_packages(d, plugindir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
88
89         postdir = bb.data.expand('${libdir}/xine/plugins/1.1.0/post', d)
90         do_split_packages(d, postdir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
91
92         fontdir = bb.data.expand('${datadir}/xine/libxine1/fonts', d)
93         do_split_packages(d, fontdir, '^(.*).xinefont.gz$', 'libxine-font-%s', 'Xine font %s', extra_depends='' )
94 }
95
96 # Omit the annoying xine-config in ${bindir}
97 FILES_${PN}="${libdir}/*.so*"
98
99 # And include it in the dev package
100 FILES_${PN}-dev += " ${bindir}"