]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/devkitidp-pxa255-kernel_2.6.11.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / devkitidp-pxa255-kernel_2.6.11.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for the BSQUARE PXA255 DevKitIDP"
3 LICENSE = "GPL"
4 MAINTAINER = "<support@bsquare.com>"
5 PR = "r2"
6
7 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.tar.bz2 \
8            ftp://ftp.accelent.com/pxa255_idp/linux/kernel-2.6.11-rc4_idp.patch;patch=1 \
9            ftp://ftp.accelent.com/pxa255_idp/linux/kernel-2.6.11_idp_leds.patch;patch=1 \
10            ftp://ftp.accelent.com/pxa255_idp/linux/devkitidp-pxa255_defconfig"
11
12 S = "${WORKDIR}/linux-2.6.11"
13
14 COMPATIBLE_HOST = 'arm.*-linux'
15
16 inherit kernel
17 inherit package
18
19 ARCH = "arm"
20 KERNEL_IMAGETYPE = "uImage"
21 #CMDLINE_CONSOLE ?= "ttyS0,115200n8"
22 #CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
23 #CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 mem=32M@0x00000000"
24 #CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
25 #CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
26 CMDLINE = "root=/dev/mtdblock2 rootfstype=jffs2 console=ttyS0,115200 mtdparts=phys_mapped_flash:256k(boot)ro,0x1C0000(kernel),-(root)"
27
28 do_configure_prepend() {
29         install -m 0644 ${WORKDIR}/${MACHINE}_defconfig ${S}/.config
30 #       echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
31 }
32
33 do_deploy() {
34         install -d ${DEPLOY_DIR}/images
35         install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
36 }
37
38 do_deploy[dirs] = "${S}"
39
40 addtask deploy before do_build after do_compile
41
42 python () {
43         # Don't build openslug kernel unless we're targeting an nslu2
44         mach = bb.data.getVar("MACHINE", d, 1)
45         if mach != 'devkitidp-pxa255':
46                 raise bb.parse.SkipPackage("This kernel only builds for the PXA255 DevKitIDP")
47 }