]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / gumstix_2.6.5-gnalm1-gum0.bb
1 BROKEN = "1"
2 #linux-2.6.5-gnalm1-gum0.patch is not fetchable 
3
4 SECTION = "kernel"
5 DESCRIPTION = "Linux kernel for OMAP processors"
6 LICENSE = "GPL"
7
8 # NOTE: pulled local linux-2.6.5-gnalm1, since it didn't apply cleanly
9 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.5.tar.bz2 \
10            file://linux-2.6.5-gnalm1.patch;patch=1 \
11            http://gumstix.superlucidity.net/downloads/kernel/patches/linux-2.6.5-gnalm1-gum0.patch;patch=1 \
12            file://defconfig"
13 S = "${WORKDIR}/linux-2.6.5"
14
15 inherit kernel
16
17 KERNEL_IMAGETYPE = "zImage"
18
19 do_configure_prepend() {
20         install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "no default configuration for ${MACHINE} available."
21         oe_runmake oldconfig
22 }
23
24 python __anonymous () {
25         import re
26         host = bb.data.getVar('HOST_SYS', d, 1)
27         if not re.match('arm.*-linux', host):
28                 raise bb.parse.SkipPackage("incompatible with host %s" % host)
29 }