]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/handhelds-pxa-2.6_2.6.11-hh2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / handhelds-pxa-2.6_2.6.11-hh2.bb
1 SECTION = "kernel"
2 DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
3 MAINTAINER = "Greg Gilbert <greg@treke.net>"
4 LICENSE = "GPL"
5 #
6 COMPATIBLE_HOST = "arm.*-linux"
7
8 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
9
10 SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
11         file://pitre-tls-2651.patch;patch=1"
12
13 S = "${WORKDIR}/kernel26"
14
15 inherit kernel
16
17 K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
18 K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
19 K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
20 HHV     = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
21
22 KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
23 do_configure() {
24         install -m 0644 arch/arm/configs/ipaqpxa_defconfig .config
25         yes '' | oe_runmake oldconfig
26 }