]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/handhelds-pxa-2.6_2.6.15-hh1.bb
77c99bed89187a85e0c0b861e9ad1532981e6a85
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / handhelds-pxa-2.6_2.6.15-hh1.bb
1 SECTION = "kernel"
2 DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
3 MAINTAINER = "Greg Gilbert <greg@treke.net>"
4 LICENSE = "GPL"
5 PR = "r1"
6
7 COMPATIBLE_HOST = "arm.*-linux"
8
9 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
10
11 SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
12         file://defconfig"
13
14 S = "${WORKDIR}/kernel26"
15
16 inherit kernel
17
18 K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
19 K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
20 K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
21 HHV     = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
22
23 KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
24 do_configure() {
25         install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "No default configuration for ${MACHINE} available."
26         yes '' | oe_runmake oldconfig
27 }
28
29 do_deploy() {
30         install -d ${DEPLOY_DIR}/images
31         install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
32 }   
33    
34 do_deploy[dirs] = "${S}"
35
36 addtask deploy before do_build after do_compile