]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/handhelds-pxa-2.6_2.6.6-hh0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / handhelds-pxa-2.6_2.6.6-hh0.bb
1 SECTION = "kernel"
2 DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
3 MAINTAINER = "Greg Gilbert <greg@treke.net>"
4 LICENSE = "GPL"
5 #
6 KERNEL_CCSUFFIX = "-3.3.4"
7 COMPATIBLE_HOST = "arm.*-linux"
8
9 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
10
11 SRC_URI = "http://handhelds.org/~michaelo/ipaq/kernel/linux-2.6.6-hh0.tar.bz2  \
12            file://defconfig-${MACHINE}"
13
14 S = "${WORKDIR}/linux-2.6.6-hh0"
15
16 inherit kernel
17
18 PACKAGE_ARCH = "ipaqpxa"
19
20 K_MAJOR = "2"
21 K_MINOR = "6"
22 K_MICRO = "6"
23 HHV     = "0"
24 #
25
26 KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
27 do_configure() {
28         install -m 0644 ${WORKDIR}/defconfig-${MACHINE} ${S}/.config || die "No default configuration for ${MACHINE} available."
29         (echo N; echo m; echo N) | oe_runmake oldconfig
30 }