]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh36.12.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / handhelds-sa_2.4.19-rmk6-pxa1-hh36.12.bb
1 SECTION = "kernel"
2 DESCRIPTION = "handhelds.org Linux kernel for StrongArm processor based devices."
3 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
4 LICENSE = "GPL"
5 PR = "r3"
6
7 KERNEL_CCSUFFIX = "-3.3.4"
8 COMPATIBLE_HOST = "arm.*-linux"
9
10 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-sa-${PV}"
11 SRC_URI = "${HANDHELDS_CVS};module=linux/kernel;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
12            file://defconfig-ipaqsa \
13            file://ipaq-hal.init \
14            file://ipsec.patch;patch=1"
15
16 S = "${WORKDIR}/kernel"
17
18 inherit kernel
19
20 PACKAGE_ARCH = "ipaqsa"
21
22 K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
23 K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
24 K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
25 RMKV    = "${@bb.data.getVar('PV',d,1).split('-')[1].split('rmk')[-1]}"
26 PXAV    = "${@bb.data.getVar('PV',d,1).split('-')[2].split('pxa')[-1]}"
27 HHV     = "${@bb.data.getVar('PV',d,1).split('-')[3].split('hh')[-1]}"
28
29 KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + int(bb.data.getVar('RMKV',d,1)) * 1000 + int(bb.data.getVar('PXAV',d,1)) * 100 + float(bb.data.getVar('HHV',d,1)))}"
30
31 module_conf_h3600_micro = "alias ipaq_hal_3600 h3600_micro"
32 module_conf_h3600_asic = "alias ipaq_hal_3800 h3600_asic"
33 module_conf_pxa_ir = "alias irda0 sa_ir"
34 module_conf_i2c_algo_pxa = "options i2c-algo-sa sa_scan=0"
35 module_conf_pcmcia_core = "options pcmcia_core ignore_cis_vcc=1"
36 module_conf_ppp_async = "alias ppp0 ppp_async"
37 module_conf_orinoco_cs = "options orinoco_cs ignore_cis_vcc=1"
38 module_conf_hostap_cs = "options hostap_cs ignore_cis_vcc=1"
39 module_conf_spectrum_cs = "options spectrum_cs ignore_cis_vcc=1"
40
41 module_autoload_h3600_generic_sleeve = "h3600_generic_sleeve"
42 module_autoload_ds = "ds"
43 module_autoload_sa1100_cs = "sa1100_cs"
44 module_autoload_h3600_ts = "h3600_ts"
45 module_autoload_apm = "apm"
46
47 FILES_kernel += "/etc/init.d/ipaq-hal"
48 INITSCRIPT_NAME = "ipaq-hal"
49 INITSCRIPT_PARAMS = "start 21 S ."
50
51 do_configure_prepend() {
52         install -m 0644 ${WORKDIR}/defconfig-${PACKAGE_ARCH} ${S}/.config
53 }
54
55 do_install_append() {
56         install -d ${D}${sysconfdir}/init.d
57         install ${WORKDIR}/ipaq-hal.init ${D}${sysconfdir}/init.d/ipaq-hal
58 }