]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh37.4.bb
df160cd1ed09963263a4f6d2df9876a29d8267d2
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / handhelds-sa_2.4.19-rmk6-pxa1-hh37.4.bb
1 SECTION = "kernel"
2 DESCRIPTION = "handhelds.org Linux kernel for StrongArm processor based devices."
3 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
4 LICENSE = "GPL"
5 PR = "r6"
6
7 KERNEL_CCSUFFIX = "-3.3.4"
8 COMPATIBLE_HOST = "arm.*-linux"
9
10 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-sa-${PV}"
11 SRC_URI = "${HANDHELDS_CVS};module=linux/kernel;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
12            file://defconfig-${PACKAGE_ARCH} \
13            file://ipaq-hal.init"
14
15 S = "${WORKDIR}/kernel"
16
17 inherit kernel update-rc.d
18
19 K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
20 K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
21 K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
22 RMKV    = "${@bb.data.getVar('PV',d,1).split('-')[1].split('rmk')[-1]}"
23 PXAV    = "${@bb.data.getVar('PV',d,1).split('-')[2].split('pxa')[-1]}"
24 HHV     = "${@bb.data.getVar('PV',d,1).split('-')[3].split('hh')[-1]}"
25
26 KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + int(bb.data.getVar('RMKV',d,1)) * 1000 + int(bb.data.getVar('PXAV',d,1)) * 100 + float(bb.data.getVar('HHV',d,1)))}"
27
28 module_conf_h3600_micro = "alias ipaq_hal_3600 h3600_micro"
29 module_conf_h3600_asic = "alias ipaq_hal_3800 h3600_asic"
30 module_conf_sa1100_ir = "alias irda0 sa1100_ir"
31 module_conf_pcmcia_core = "options pcmcia_core ignore_cis_vcc=1"
32 module_conf_ppp_async = "alias ppp0 ppp_async"
33 module_conf_orinoco_cs = "options orinoco_cs ignore_cis_vcc=1"
34 module_conf_hostap_cs = "options hostap_cs ignore_cis_vcc=1"
35 module_conf_spectrum_cs = "options spectrum_cs ignore_cis_vcc=1"
36
37 module_autoload_h3600_ts = "h3600_ts"
38 module_autoload_apm = "apm"
39 module_autoload_h3600-uda1341 = "h3600-uda1341"
40 module_autoload_af_packet = "af_packet"
41 module_autoload_ppp_async = "ppp_async"
42 module_autoload_usb-eth = "usb-eth"
43
44 FILES_kernel += "/etc/init.d/ipaq-hal"
45 INITSCRIPT_NAME = "ipaq-hal"
46 INITSCRIPT_PARAMS = "start 21 S ."
47
48 do_configure_prepend() {
49         install -m 0644 ${WORKDIR}/defconfig-${PACKAGE_ARCH} ${S}/.config
50 }
51
52 do_install_append() {
53         install -d ${D}${sysconfdir}/init.d
54         install ${WORKDIR}/ipaq-hal.init ${D}${sysconfdir}/init.d/ipaq-hal
55 }