]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/linux-colinux_2.4.28.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / linux-colinux_2.4.28.bb
1 SECTION = "kernel"
2 DESCRIPTION = "User Mode Linux Kernel"
3 LICENSE = "GPL"
4 COLV = "0.6.1"
5
6 #http://internap.dl.sourceforge.net/sourceforge/colinux/coLinux-0.6.1.tar.gz
7 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
8            file://colinux-${COLV}.patch;patch=1 \
9            file://nofpu.patch;patch=1 \
10            file://shortloadbytes.patch;patch=1 \
11            file://gcc-registerparanoia.patch;patch=1 \
12            file://linux-2.4.24-attribute-used.patch;patch=1 \
13            file://gcc340-fixes-v2.4.26-try3.patch;patch=1 \
14            file://defconfig"
15
16 S = "${WORKDIR}/linux-${PV}"
17
18 inherit kernel
19
20 COMPATIBLE_HOST = "i.86.*-linux"
21 KERNEL_IMAGETYPE = "vmlinux"
22 KERNEL_OUTPUT = "./${KERNEL_IMAGETYPE}"
23
24 do_configure() {
25         install -m 0644 ${WORKDIR}/defconfig .config
26         kernel_do_configure
27 }