]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/linux-colinux_2.6.10.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / linux-colinux_2.6.10.bb
1 SECTION = "kernel"
2 DESCRIPTION = "User Mode Linux Kernel"
3 LICENSE = "GPL"
4 COLV = "0.6.2"
5
6 #http://internap.dl.sourceforge.net/sourceforge/colinux/coLinux-${COLV}.tar.gz
7 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
8            file://colinux-${COLV}.patch;patch=1 \
9            file://defconfig"
10
11 S = "${WORKDIR}/linux-${PV}"
12
13 inherit kernel
14
15 COMPATIBLE_HOST = "i.86.*-linux"
16 KERNEL_IMAGETYPE = "vmlinux"
17 KERNEL_OUTPUT = "./${KERNEL_IMAGETYPE}"
18
19 do_configure() {
20         echo '-co-${COLV}' > localversion-cooperative
21         install -m 0644 ${WORKDIR}/defconfig .config
22         kernel_do_configure
23 }