]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/linux-geodegx_2.4.24.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / linux-geodegx_2.4.24.bb
1 # Linux kernel OE build file for the AMD Geode GX processor
2 # Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 KV = "2.4.24"
6 DESCRIPTION = "Linux kernel for the AMD Geode GX processor"
7 LICENSE = "GPL"
8
9 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
10         http://www.amd.com/files/connectivitysolutions/geode/Patches_Linux_${KV}_1.00.tar.gz \
11         file://${WORKDIR}/Patches_Linux_${KV}_1.00/linux-${KV}-geode.patch;patch=1 \
12         file://linux-2.4.24-gcc340-fixes.patch;patch=1 \
13         file://defconfig"
14
15 S = "${WORKDIR}/linux-${KV}"
16
17 inherit kernel 
18
19 ARCH = "i386"
20 KERNEL_IMAGETYPE = "bzImage"
21
22 do_configure_prepend() {
23         install -m 0644 ${WORKDIR}/defconfig ${S}/.config 
24         oe_runmake oldconfig
25 }