]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/linux-mtx-1_2.4.27.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / linux-mtx-1_2.4.27.bb
1 DESCRIPTION = "Linux kernel for MTX-1 (MeshCube)"
2 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
3 HOMEPAGE = "http://meshcube.org/meshwiki/"
4 LICENSE = "GPL"
5 KV = "${PV}"
6 PR = "r3"
7 RDEPENDS = "mtd-utils"
8
9 SRC_URI = "cvs://cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4_27 \
10         file://01-mtd-2004-01-27.diff;patch=1 \
11         file://02-mtd-mtx-1-map.diff;patch=1 \
12         file://03-mtd-erase-compiler-bug.diff;patch=1 \
13         file://04-mtx-1-board-reset.diff;patch=1 \
14         file://05-mtx-1-pci-irq.diff;patch=1 \
15         file://06-zboot-2.4.26.patch;patch=1 \
16         file://07-zboot-zimage-flash-bin.diff;patch=1 \
17         file://08-usb-nonpci-2.4.24.patch;patch=1 \
18         file://09-au1000-eth-vlan.diff;patch=1 \
19         file://10-iw-max-spy-32.diff;patch=1 \
20         file://11-mtd-proc-partition-rw.diff;patch=1 \
21         file://12-openswan-2.2.0-nat-t.diff;patch=1 \
22         file://13-openswan-2.2.0.patch;patch=1 \
23         file://14-au1000-eth-link-beat.diff;patch=1 \
24         file://16-i2c.patch;patch=1 \
25         file://17-lmsensors.2.8.8.patch;patch=1 \
26         file://18-i2c-au1x00gpio.patch;patch=1 \
27         file://19-kernel-make-depend.diff;patch=1 \
28         file://20-au1x00_ethernet_tx_stats.diff;patch=1 \
29         file://21-mtx-1-watchdog.diff;patch=1 \
30         file://defconfig-mtx-1"
31
32 S = "${WORKDIR}/linux"
33
34 inherit kernel
35
36 COMPATIBLE_HOST = "mipsel.*-linux"
37 PACKAGE_ARCH = "mtx-1"
38 ARCH = "mips"
39 KERNEL_OUTPUT = "arch/mips/zboot/images/mtx-1.flash.bin"
40 KERNEL_IMAGETYPE = "zImage.flash"
41 KERNEL_IMAGEDEST = "tmp"
42
43 do_configure_prepend() {
44         install -m 0644 ${WORKDIR}/defconfig-mtx-1 ${S}/.config
45 }
46
47 pkg_postinst_kernel() {
48 if test "x$D" != "x"; then
49         exit 1
50 else
51         if test -e /tmp/zImage.flash-${KV}; then
52                 echo "*** flashing kernel ***"
53                 flashcp -v /tmp/zImage.flash-${KV} /dev/mtd/2
54                 echo "*** done. please reboot ***"
55         fi
56 fi
57 }
58
59 FILES_kernel += " /tmp"
60
61 do_deploy() {
62         install -d ${DEPLOY_DIR}/images
63         install -m 0644 arch/mips/zboot/images/mtx-1.flash.bin ${DEPLOY_DIR}/images/${KERNEL_IMAGE_NAME}.flash.bin
64         install -m 0644 arch/mips/zboot/images/mtx-1.flash.srec ${DEPLOY_DIR}/images/${KERNEL_IMAGE_NAME}.flash.srec
65         install -m 0644 arch/mips/zboot/images/mtx-1.srec ${DEPLOY_DIR}/images/${KERNEL_IMAGE_NAME}.ram.srec
66 }
67
68 do_deploy[dirs] = "${S}"
69
70 addtask deploy before do_build after do_compile