]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/linux-omap1_2.6.12-rc2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / linux-omap1_2.6.12-rc2.bb
1 PR      = "r3"
2 SECTION = "kernel"
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 LICENSE = "GPL"
5
6 SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/testing/linux-2.6.12-rc2.tar.bz2 \
7            http://www.muru.com/linux/omap/patches/patch-2.6.12-rc2-omap1.bz2;patch=1 \
8            file://defconfig"
9
10
11 S = "${WORKDIR}/linux-2.6.12-rc2"
12
13 KERNEL_IMAGETYPE = "vmlinux"
14 KERNEL_OUTPUT = "arch/${ARCH}/boot/compressed/${KERNEL_IMAGETYPE}"
15 KERNEL_CCSUFFIX = "-3.3.4"
16
17 #DEPENDS = "uboot"
18
19 inherit kernel
20
21 python __anonymous () {
22         import re
23         host = bb.data.getVar('HOST_SYS', d, 1)
24         if not re.match('arm.*-linux', host):
25                 raise bb.parse.SkipPackage("incompatible with host %s" % host)
26 }
27
28
29 do_configure_prepend() {
30         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
31         oe_runmake oldconfig
32 }
33
34 do_deploy_omap5912osk() {
35         install -d ${DEPLOY_DIR}/images
36         arm-linux-objcopy -O binary -R .note -R .comment -S arch/arm/boot/compressed/vmlinux ${DEPLOY_DIR}/linux.bin
37         gzip -f -9 ${DEPLOY_DIR}/linux.bin
38         mkimage -A arm -O linux -T kernel -C gzip -a 0x10c08000 -e 0x10c08000 -n "OE" -d ${DEPLOY_DIR}/linux.bin.gz ${DEPLOY_DIR}/uImage_bb.cc
39         cp ${DEPLOY_DIR}/uImage_bb.cc /tftpboot
40 #        install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
41 }
42
43
44 do_deploy[dirs] = "${S}"
45
46 addtask deploy before do_build after do_compile