]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/linux-sun4cdm_2.4.26.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / linux-sun4cdm_2.4.26.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for sparc32/sun4c"
3 LICENSE = "GPL"
4 PR = "r0"
5 DEPENDS += "elftoaout-native"
6
7 KERNEL_CCSUFFIX = "-3.3.4"
8
9 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
10            file://defconfig"
11 S = "${WORKDIR}/linux-${PV}"
12
13 COMPATIBLE_HOST = 'sparc-linux'
14
15 inherit kernel
16
17 ARCH = "sparc"
18 KERNEL_IMAGETYPE = "vmlinux"
19 KERNEL_OUTPUT = "vmlinux"
20
21 do_configure_prepend() {
22         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
23 }
24
25 do_deploy() {
26         install -d ${DEPLOY_DIR}/images
27         elftoaout -o ${DEPLOY_DIR}/images/linux-aout-${DATETIME} ${KERNEL_IMAGETYPE}
28 }
29
30 do_deploy[dirs] = "${S}"
31
32 addtask deploy before do_build after do_compile