]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/mainstone-kernel_2.6.11.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / mainstone-kernel_2.6.11.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for the Mainstone (PXA270 ref design)"
3 LICENSE = "GPL"
4 MAINTAINER = "Cliff Brake <cliff.brake@gmail.com>"
5 PR = "r1"
6
7 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.tar.bz2 \
8            file://mainstone_defconfig"
9
10 S = "${WORKDIR}/linux-2.6.11"
11
12 COMPATIBLE_HOST = 'arm.*-linux'
13
14 inherit kernel
15 inherit package
16
17 ARCH = "arm"
18 KERNEL_IMAGETYPE = "zImage"
19 #CMDLINE_CONSOLE ?= "ttyS0,115200n8"
20 #CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
21 #CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 mem=32M@0x00000000"
22 #CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
23 #CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
24
25 do_configure_prepend() {
26         install -m 0644 ${WORKDIR}/${MACHINE}_defconfig ${S}/.config
27 #       echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
28 }
29
30 do_deploy() {
31         install -d ${DEPLOY_DIR}/images
32         install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
33 }
34
35 do_deploy[dirs] = "${S}"
36
37 addtask deploy before do_build after do_compile
38
39 python () {
40         # Don't build kernel unless we're targeting a mainstone
41         mach = bb.data.getVar("MACHINE", d, 1)
42         if mach != 'mainstone':
43                 raise bb.parse.SkipPackage("This kernel only builds for the Mainstone")
44 }