]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / mnci-ramses_2.4.21-rmk2-pxa1.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for MNCI device"
3 MAINTAINER = "M&N Solutions <info@mn-solutions.de>"
4 LICENSE = "GPL"
5 DEPENDS = "modutils-cross virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX}"
6 COMPATIBLE_HOST = "arm.*-linux"
7 KV = "2.4.21"
8 RMKV = "2"
9 PXAV = "1"
10 PR = "r5"
11
12 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
13            http://lorien.handhelds.org/ftp.arm.linux.org.uk/kernel/v2.4/patch-${KV}-rmk${RMKV}.bz2;patch=1 \
14            file://diff-${KV}-rmk${RMKV}-pxa${PXAV}.gz;patch=1 \
15            file://mnci-combined.patch;patch=1"
16
17 S = "${WORKDIR}/linux-${KV}"
18
19 inherit kernel
20
21 KERNEL_CCSUFFIX = "-3.3.4"
22
23 # Put the zImage into kernel-image
24 ALLOW_EMPTY_kernel = "1"
25 FILES_kernel = ""
26 FILES_kernel-image += "/tmp/zImage"
27
28 do_configure_prepend() {
29         install -m 0644 ${S}/arch/arm/def-configs/${MACHINE} ${S}/.config || die "No default configuration for ${MACHINE} available."
30 }
31
32 kernel_do_install() {
33         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
34         if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
35                 oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" modules_install
36         else
37                 oenote "no modules to install"
38         fi
39         install -d ${D}/tmp
40         install -m 0644 ${KERNEL_OUTPUT} ${D}/tmp
41         install -d ${D}/boot
42         install -m 0644 .config ${D}/boot/config-${PV}
43         bzip2 -9 ${D}/boot/*
44         install -d ${D}${sysconfdir}/modutils
45 }
46
47
48 pkg_postinst_kernel-image () {
49 test -f /tmp/zImage || exit 0
50 cp /tmp/zImage /dev/mtdblock/1
51 rm /tmp/zImage
52 sync
53 cat /dev/mtdblock/1 >/dev/null
54 }
55
56 pkg_postinst_kernel () {
57 }
58
59 pkg_postinst_modules () {
60 if [ -n "$D" ]; then
61         ${HOST_PREFIX}depmod -A -b $D -F $D/boot/System.map-${PV} ${KERNEL_VERSION}
62 else
63         depmod -A
64 fi
65 }
66
67 pkg_postrm_modules () {
68 }
69
70 pkg_postrm_kernel () {
71 }
72