]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/triton-kernel_2.6.11.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / triton-kernel_2.6.11.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for the KARO TRITON XScale Board"
3 LICENSE = "GPL"
4 MAINTAINER = "Justin Huff <jjhuff@mspin.net"
5 PR = "r0"
6
7 KERNEL_SUFFIX = "triton"
8
9 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
10            ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/${PV}/${PV}-mm2/${PV}-mm2.bz2;patch=1 \
11                    file://patch-2.6.11-mm2-karo9.bz2;patch=1 \
12                    file://defconfig"
13  
14 S = "${WORKDIR}/linux-${PV}"
15
16 COMPATIBLE_HOST = 'arm.*-linux'
17
18 inherit kernel
19
20 ARCH = "arm"
21 KERNEL_IMAGETYPE = "zImage"
22 CMDLINE ?= "root=/dev/mtdblock2 rw rootfstype=jffs2 reboot=5"
23
24 do_configure_prepend() {
25         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
26         echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
27         rm -rf ${S}/include/asm-arm/arch ${S}/include/asm-arm/proc \
28                ${S}/include/asm-arm/.proc ${S}/include/asm-arm/.arch
29 }
30
31 do_deploy() {
32         install -d ${DEPLOY_DIR}/images
33         install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${KERNEL_SUFFIX}
34 }
35
36 do_deploy[dirs] = "${S}"
37
38 addtask deploy before do_build after do_compile
39
40 python () {
41         # Don't build kernel unless we're targeting an triton
42         mach = bb.data.getVar("MACHINE", d, 1)
43         if mach != 'triton':
44                 raise bb.parse.SkipPackage("The triton kernel is only for use on triton machines")
45 }