]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/unslung-kernel_2.4.22.l2.3r29.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / unslung-kernel_2.4.22.l2.3r29.bb
1 SECTION = "kernel"
2
3 include nslu2-linksys-kernel_2.4.22.bb
4
5 DESCRIPTION = "Unslung kernel for the Linksys NSLU2 device"
6 MAINTAINER = "NSLU2 Linux <www.nlsu2-linux.org>"
7 PR = "r5"
8
9 KERNEL_SUFFIX = "unslung"
10
11 CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 rw init=/linuxrc mem=32M@0x00000000"
12
13 UNSLUNG_KERNEL_EXTRA_SRC_URI ?=
14
15 SRC_URI += "file://limit1gb.patch;patch=1 \
16             file://gl811e.patch;patch=1 \
17             file://ext3flash-on-disk1.patch;patch=1 \
18             file://usbnet.patch;patch=1 \
19             file://missing-usb-ioctls.patch;patch=1 \
20             file://anonymiser.patch;patch=1 \
21             file://ppp_mppe.patch;patch=1 \
22             file://nfs-blocksize.patch;patch=1 \
23             file://pl2303.patch;patch=1 \
24             file://linux-kernel-R25_to_R29.patch;patch=1 \
25             ${UNSLUNG_KERNEL_EXTRA_SRC_URI}"
26
27 FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/unslung-kernel', '${FILE_DIRNAME}/nslu2-linksys-kernel-2.4.22', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
28
29 python () {
30         # Don't build unslung kernel unless we're targeting an nslu2
31         mach = bb.data.getVar("MACHINE", d, 1)
32         dist = bb.data.getVar("DISTRO", d, 1)
33         if mach != 'nslu2' or dist != 'unslung':
34                 raise bb.parse.SkipPackage("Unslung only builds for the Linksys NSLU2")
35 }