]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux-uml/linux-uml_2.6.11-rc2-mm1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux-uml / linux-uml_2.6.11-rc2-mm1.bb
1 DESCRIPTION = "User Mode Linux Kernel"
2 SECTION = "kernel"
3 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
4 LICENSE = "GPL"
5 KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
6 RCV = "${@bb.data.getVar('PV',d,True).split('-')[1]}"
7 MMV = "${@bb.data.getVar('PV',d,True).split('-')[2]}"
8 LV = "2.6.10"
9 PR = "r3"
10
11 SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-${LV}.tar.bz2 \
12            http://www.kernel.org/pub/linux/kernel/v2.6/testing/patch-${KV}-${RCV}.bz2;patch=1 \
13            http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/${KV}-${RCV}/${KV}-${RCV}-${MMV}/${KV}-${RCV}-${MMV}.gz;patch=1 \
14            file://defconfig"
15 #http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-core-on-panic;patch=1 \
16 #http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-pretend-to-be-i586;patch=1 \
17 #http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-general-protection-fault;patch=1 \
18 #http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-x11-fb;patch=1 \
19
20 S = "${WORKDIR}/linux-${LV}"
21
22 inherit kernel
23
24 COMPATIBLE_HOST = 'i.86.*-linux'
25
26 export OS = "Linux"
27 ARCH = "um"
28 SUBARCH = "${TARGET_ARCH}"
29 KERNEL_IMAGETYPE = "linux"
30 EXTRA_OEMAKE = "'CC=${KERNEL_CC}' 'LD=${KERNEL_LD}' \
31                 'SUBARCH=${SUBARCH}'"
32 EXTRA_CFLAGS += "-I${includedir}"
33
34 do_configure() {
35         install -m 0644 ${WORKDIR}/defconfig .config
36         oe_runmake oldconfig
37 }
38
39 do_compile() {
40         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
41         install -d arch/um/include/linux/
42         install -m 0644 include/linux/inet.h arch/um/include/linux/
43         kernel_do_compile
44 }
45
46 do_stage_prepend() {
47         install -d arch/um/boot/
48         ln -sf ${S}/linux arch/um/boot/linux
49 }
50
51 do_install() {
52         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
53         #oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" modules_install
54         install -d ${D}/boot
55         install -m 0755 linux ${D}/boot/linux-${PV}
56         install -m 0644 System.map ${D}/boot/System.map-${PV}
57         install -m 0644 .config ${D}/boot/config-${PV}
58 }