]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/lirc/lirc-modules_0.7.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / lirc / lirc-modules_0.7.0.bb
1 DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
2 SECTION = "base"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 DEPENDS = "virtual/kernel fakeroot-native"
7 PR = "r3"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \
10            file://lirc_sir-sa1100.patch;patch=1"
11 S = "${WORKDIR}/lirc-${PV}"
12
13 inherit autotools module-base
14
15 include lirc-config.inc
16
17 do_compile() {
18         # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them
19         cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS=""
20 }
21
22 fakeroot do_install() {
23         oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
24         rm -rf ${D}/dev
25 }
26
27 pkg_postinst() {
28 #!/bin/sh
29  mknod /dev/lirc c 61 0
30  if [ -n $D ]; then exit 1; fi
31 }
32
33 FILES_${PN} = "/lib/modules"