]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/lirc/lirc_0.6.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / lirc / lirc_0.6.6.bb
1 DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
2 SECTION = "console/network"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 DEPENDS = "virtual/kernel"
7 PR = "r6"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz"
10 S = "${WORKDIR}/lirc-${PV}"
11
12 inherit autotools module-base
13
14 EXTRA_OECONF_epia = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=serial"
15 EXTRA_OECONF_collie = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
16 EXTRA_OECONF_h3600 = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
17 EXTRA_OECONF_simpad = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
18
19 EXTRA_OEMAKE = 'SUBDIRS="daemons tools"'
20
21 do_stage() {
22         oe_libinstall -so -C tools liblirc_client ${STAGING_LIBDIR}
23         install -d ${STAGING_INCDIR}/lirc/
24         install -m 0644 tools/lirc_client.h ${STAGING_INCDIR}/lirc/
25 }
26
27 do_install() {
28         install -d ${D}${bindir}
29
30         install -m 755 daemons/irrecord ${D}${bindir}/irrecord
31         install -m 755 daemons/lircd ${D}${bindir}/lircd
32         install -m 755 tools/rc ${D}${bindir}/rc
33
34         oe_libinstall -so -C tools liblirc_client ${D}${libdir}/
35         install -d ${D}${includedir}
36         install -m 0644 tools/lirc_client.h ${D}${includedir}/
37 }
38