]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/lirc/lirc_0.7.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / lirc / lirc_0.7.0.bb
1 DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
2 SECTION = "console/network"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 DEPENDS = "virtual/kernel"
7 PR = "r6"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \
10       file://split-hauppauge.patch;patch=1 \
11       file://lircd.init file://lircmd.init"
12 S = "${WORKDIR}/lirc-${PV}"
13
14 inherit autotools module-base update-rc.d
15
16 INITSCRIPT_NAME = "lirc"
17 INITSCRIPT_PARAMS = "defaults 20"
18
19 include lirc-config.inc
20
21 EXTRA_OEMAKE = 'SUBDIRS="daemons tools"'
22
23 do_stage() {
24         oe_libinstall -so -C tools liblirc_client ${STAGING_LIBDIR}
25         install -d ${STAGING_INCDIR}/lirc/
26         install -m 0644 tools/lirc_client.h ${STAGING_INCDIR}/lirc/
27 }
28
29 do_install_append() {
30         install -d ${D}${sysconfdir}/init.d
31         install ${WORKDIR}/lircd.init ${D}${sysconfdir}/init.d/lircd
32
33         install -d ${D}${datadir}/lirc/
34         cp -pPR ${S}/remotes ${D}${datadir}/lirc/
35 }
36