]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/lockstat/lockstat_1.4.10.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / lockstat / lockstat_1.4.10.bb
1 SECTION = "console/utils"
2 DESCRIPTION = "A tool for retrieving kernel spinlock metering information."
3 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
4 DEPENDS = "virtual/kernel"
5
6 SRC_URI = "ftp://oss.sgi.com/projects/lockmeter/download/lockstat-${PV}.tar.gz"
7 S = "${WORKDIR}/lockstat"
8
9 export KERNEL_VERSION = ${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}
10 export KERNEL_SOURCE = ${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}
11 CFLAGS += " -I${KERNEL_SOURCE}/include"
12
13 python () {
14 # NOTE: any target machines with kernels supporting spinlock metering should
15 # check the MACHINE variable here to prevent the SkipPackage.
16         raise bb.parse.SkipPackage("The target machine's kernel does not appear able to use spinlock metering.")
17 }
18
19 do_compile () {
20         oe_runmake
21 }
22
23 do_install () {
24         install -d ${D}${sbindir}
25         install -m 0755 lockstat ${D}${sbindir}/
26 }