]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ltt/ltt_0.9.5a+0.9.6pre2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ltt / ltt_0.9.5a+0.9.6pre2.bb
1 SECTION = "devel"
2 DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
3 extract program execution details from the Linux operating system and  \
4 interpret them."
5 LICENSE = "GPL"
6 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
7
8 # NOTE: we're applying the relayfs patch.  therefore, this version of the
9 # tools will only work with a kernel that uses that particular incarnation
10 # of the ltt patch.  We probably need a way to exert control over this
11 # based on a variable that ${MACHINE}.conf can manipulate.
12 SRC_URI = "http://www.opersys.com/ftp/pub/LTT/TraceToolkit-0.9.6pre2.tgz \
13            http://www.opersys.com/ftp/pub/relayfs/LTT/patch-ltt-on-relayfs-0.9.6pre2.bz2;patch=1 \
14            file://gcc34.patch;patch=1 \
15            file://m4.patch;patch=1"
16 S = "${WORKDIR}/TraceToolkit-0.9.6pre2"
17
18 inherit autotools
19
20 INHIBIT_PACKAGE_STRIP = "1"
21 EXTRA_OECONF = "--without-rtai \
22                 --without-gtk"
23
24 do_configure () {
25         rm -f ${S}/acinclude.m4
26         autotools_do_configure
27 }